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Mail sent to a hosted domain does not arrive if third-party MX records are present

Overview

Mail sent to a domain hosted by your account that uses third-party MX records does not arrive to the intended recipient. Mail is instead delivered locally to the server that hosts your domain.

For example, if example.com uses Google Apps to handle e-mail, and mail originates from the same hosting server as in from a script, like a contact form on a WordPress blog, mail would not reach its intended recipient at contact@example.com, which is accessed through Google Mail. Mail, instead, would be delivered to the local user named contact on the server.

Cause

The domain is present in MailMail Routing within the control panel. Any domain present in this list will bypass MX record lookups and the server will act as its final destination.

Solution

Visit MailMail Routing within the control panel and deauthorize the server from handling mail for that domain by deleting the record.

Updated on July 8, 2019

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